mcommit's message

ソフトウェア開発の仕事をしているsimotinといいます。記事の内容でご質問やご意見がありましたらお気軽にコメントしてください\^o^/

Elixir入門 ~8日目 HTTPoisonを動かすにはElixir1.2が必要だった~

昨日の続き。

mixが動くようになって、 mix.exs を編集して mix deps.get でモジュールをダウンロードするところまではできた。

と、思っていた。


今日はGithub

github.com


を参考にいざ動かそうとしたら以下のようなエラーメッセージがでた・・・

今度はなんだ?いい加減エラーメッセージでコンソールが真っ赤に染まるのには飽きてきた。

$ iex -S mix
Erlang/OTP 18 [erts-7.3] [source] [64-bit] [async-threads:10] [kernel-poll:false]

==> httpoison
warning: the dependency httpoison requires Elixir "~> 1.2" but you are running on v1.1.0-dev

== Compilation error on file lib/httpoison/base.ex ==
** (CompileError) lib/httpoison/base.ex:452: function '<-'/2 undefined
    (stdlib) lists.erl:1337: :lists.foreach/2
    (stdlib) erl_eval.erl:670: :erl_eval.do_apply/6

「httpoison を動かしたかったらElixir 1.2 を入れな!」

ということらしい。

httpoison のバージョンとかおとしたらもしかしたら動くのかもしれないが今日はやめておく。

その前に一言。

やりたいことができないこんなElixirじゃ、ぽいぞん。

そもそもどのレイヤーで依存関係が発生しているのかよく分からないがそんなに動かなくなるものかね・・・

mix 動かしたいだけなのに。


まぁ愚痴ってもしょうがないので今度はElixirのバージョンアップから試そう。